Syntax error, parameterized types are only available if source level is 1.5 解决方案

      在网上找了一个K-means算法的程序,打开,运行,出现了Syntax error,parameterized types are only available if source level is 5.0 or graeter的情况,错误代码为: ArrayList<float[]> dataSet=new ArrayList<float[]>(); 

        在Eclipse中,菜单条 —“Windows” —-“preferneces”  在弹出对话框中 ,在左侧列表框中 选择 “JAVA” —子菜单中 “compiler” … 然后在右侧把 “Compiler compliance level” 设置成1.5.0以上 即可。

       设置好以后  按F5键 刷新即可。如果没反应,多刷新几次试试即可!   

Sea Bridge

古之立大志者,不惟有超世之才 亦必有坚韧不拔之志!

发表评论